blob: 18d6a4f27cee54ae43589626bcbd96f79b769b21 [file] [log] [blame]
Patrick Williams93c203f2021-10-06 16:15:23 -05001SUMMARY = "An IPC library for high performance servers"
2DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \
3It provides high performance logging, tracing, ipc, and poll."
4
5HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
6SECTION = "libs"
7LICENSE = "LGPL-2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
9
10inherit autotools pkgconfig
11
12SRCREV = "404adbcd998ec83643e47d92b3ea8d9c3970e68b"
13SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \
14 "
15S = "${WORKDIR}/git"
16
17DEPENDS += "libxml2"
18
19CFLAGS += "-pthread -D_REENTRANT"
20
21do_configure:prepend() {
22 ( cd ${S}
23 ${S}/autogen.sh )
24}
25
26BBCLASSEXTEND = "native"