blob: 62aa1b0e877565bc0475b4a8eff414e49d6c9cf8 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Multi-purpose linux bootloader"
2HOMEPAGE = "http://www.syslinux.org/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "The Syslinux Project covers lightweight bootloaders for MS-DOS FAT filesystems (SYSLINUX), network booting (PXELINUX), bootable "El Torito" CD-ROMs (ISOLINUX), and Linux ext2/ext3/ext4 or btrfs filesystems (EXTLINUX). The project also includes MEMDISK, a tool to boot legacy operating systems (such as DOS) from nontraditional media; it is usually used in conjunction with PXELINUX and ISOLINUX."
Brad Bishop19323692019-04-05 15:28:33 -04004LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
6 file://README;beginline=35;endline=41;md5=558f2c71cb1fb9ba511ccd4858e48e8a"
7
Brad Bishop19323692019-04-05 15:28:33 -04008DEPENDS = "nasm-native util-linux e2fsprogs"
Brad Bishop19323692019-04-05 15:28:33 -04009
10SRC_URI = "https://www.zytor.com/pub/syslinux/Testing/6.04/syslinux-${PV}.tar.xz \
11 file://syslinux-remove-clean-script.patch \
12 file://0001-linux-syslinux-support-ext2-3-4-device.patch \
13 file://0002-linux-syslinux-implement-open_ext2_fs.patch \
14 file://0003-linux-syslinux-implement-install_to_ext2.patch \
15 file://0004-linux-syslinux-add-ext_file_read-and-ext_file_write.patch \
16 file://0005-linux-syslinux-implement-handle_adv_on_ext.patch \
17 file://0006-linux-syslinux-implement-write_to_ext-and-add-syslin.patch \
18 file://0007-linux-syslinux-implement-ext_construct_sectmap_fs.patch \
19 file://0008-libinstaller-syslinuxext-implement-syslinux_patch_bo.patch \
20 file://0009-linux-syslinux-implement-install_bootblock.patch \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050021 file://0010-Workaround-multiple-definition-of-symbol-errors.patch \
Brad Bishop19323692019-04-05 15:28:33 -040022 file://0001-install-don-t-install-obsolete-file-com32.ld.patch \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060023 file://determinism.patch \
Brad Bishop19323692019-04-05 15:28:33 -040024 "
25
26SRC_URI[md5sum] = "2b31c78f087f99179feb357da312d7ec"
27SRC_URI[sha256sum] = "4441a5d593f85bb6e8d578cf6653fb4ec30f9e8f4a2315a3d8f2d0a8b3fadf94"
28
Andrew Geissler90fd73c2021-03-05 15:25:55 -060029# remove at next version upgrade or when output changes
30PR = "r1"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060031
Andrew Geisslerd1e89492021-02-12 15:35:20 -060032RECIPE_NO_UPDATE_REASON = "6.04-pre3 is broken"
Brad Bishop19323692019-04-05 15:28:33 -040033UPSTREAM_CHECK_URI = "https://www.zytor.com/pub/syslinux/"
34UPSTREAM_CHECK_REGEX = "syslinux-(?P<pver>.+)\.tar"
35UPSTREAM_VERSION_UNKNOWN = "1"
36
Andrew Geisslerd1e89492021-02-12 15:35:20 -060037# We can build the native parts anywhere, but the target has to be x86
Patrick Williams213cb262021-08-07 19:21:33 -050038COMPATIBLE_HOST:class-target = '(x86_64|i.86).*-(linux|freebsd.*)'
Andrew Geisslerd1e89492021-02-12 15:35:20 -060039
Brad Bishop19323692019-04-05 15:28:33 -040040# Don't let the sanity checker trip on the 32 bit real mode BIOS binaries
Patrick Williams213cb262021-08-07 19:21:33 -050041INSANE_SKIP:${PN}-misc = "arch"
42INSANE_SKIP:${PN}-chain = "arch"
Brad Bishop19323692019-04-05 15:28:33 -040043
Andrew Geisslerd1e89492021-02-12 15:35:20 -060044# When building the installer, CC is used to link. When building the bootloader,
45# LD is used. However, these variables assume that GCC is used and break the
46# build, so unset them.
47TARGET_LDFLAGS = ""
48SECURITY_LDFLAGS = ""
49LDFLAGS_SECTION_REMOVAL = ""
50
Patrick Williams213cb262021-08-07 19:21:33 -050051CFLAGS:append = " -DNO_INLINE_FUNCS"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060052
Brad Bishop19323692019-04-05 15:28:33 -040053EXTRA_OEMAKE = " \
54 BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \
55 DATADIR=${datadir} MANDIR=${mandir} INCDIR=${includedir} \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060056 CC="${CC} ${CFLAGS} ${LDFLAGS}" \
57 LD="${LD} ${LDFLAGS}" \
58 OBJDUMP="${OBJDUMP}" \
59 OBJCOPY="${OBJCOPY}" \
60 AR="${AR}" \
61 STRIP="${STRIP}" \
62 NM="${NM}" \
63 RANLIB="${RANLIB}" \
Brad Bishop19323692019-04-05 15:28:33 -040064"
65
Andrew Geisslerd1e89492021-02-12 15:35:20 -060066#
67# Tasks for native/nativesdk which just build the installer.
68#
Brad Bishop19323692019-04-05 15:28:33 -040069do_configure() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -060070 oe_runmake firmware="bios" clean
Brad Bishop19323692019-04-05 15:28:33 -040071}
72
73do_compile() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -060074 oe_runmake firmware="bios" installer
Brad Bishop19323692019-04-05 15:28:33 -040075}
76
77do_install() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -060078 install -d ${D}${bindir}
79 install \
80 ${B}/bios/mtools/syslinux \
81 ${B}/bios/extlinux/extlinux \
82 ${B}/bios/utils/isohybrid \
83 ${D}${bindir}
84}
85
86#
87# Tasks for target which ship the precompiled bootloader and installer
88#
Patrick Williams213cb262021-08-07 19:21:33 -050089do_configure:class-target() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -060090 # No need to do anything as we're mostly shipping the precompiled binaries
91 :
92}
93
Patrick Williams213cb262021-08-07 19:21:33 -050094do_compile:class-target() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -060095 # No need to do anything as we're mostly shipping the precompiled binaries
96 :
97}
98
Patrick Williams213cb262021-08-07 19:21:33 -050099do_install:class-target() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600100 oe_runmake firmware="bios" install INSTALLROOT="${D}"
Brad Bishop19323692019-04-05 15:28:33 -0400101
102 install -d ${D}${datadir}/syslinux/
103 install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/
104 install -m 644 ${S}/bios/core/ldlinux.bss ${D}${datadir}/syslinux/
Brad Bishop19323692019-04-05 15:28:33 -0400105}
106
107PACKAGES += "${PN}-nomtools ${PN}-extlinux ${PN}-mbr ${PN}-chain ${PN}-pxelinux ${PN}-isolinux ${PN}-misc"
108
Patrick Williams213cb262021-08-07 19:21:33 -0500109RDEPENDS:${PN} += "mtools"
110RDEPENDS:${PN}-nomtools += "libext2fs"
111RDEPENDS:${PN}-misc += "perl"
Brad Bishop19323692019-04-05 15:28:33 -0400112
Patrick Williams213cb262021-08-07 19:21:33 -0500113FILES:${PN} = "${bindir}/syslinux"
114FILES:${PN}-nomtools = "${bindir}/syslinux-nomtools"
115FILES:${PN}-extlinux = "${sbindir}/extlinux"
116FILES:${PN}-mbr = "${datadir}/${BPN}/mbr.bin"
117FILES:${PN}-chain = "${datadir}/${BPN}/chain.c32"
118FILES:${PN}-isolinux = "${datadir}/${BPN}/isolinux.bin"
119FILES:${PN}-pxelinux = "${datadir}/${BPN}/pxelinux.0"
120FILES:${PN}-dev += "${datadir}/${BPN}/com32/lib*${SOLIBS} ${datadir}/${BPN}/com32/include ${datadir}/${BPN}/com32/com32.ld"
121FILES:${PN}-staticdev += "${datadir}/${BPN}/com32/lib*.a ${libdir}/${BPN}/com32/lib*.a"
122FILES:${PN}-misc = "${datadir}/${BPN}/* ${libdir}/${BPN}/* ${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -0400123
124BBCLASSEXTEND = "native nativesdk"