blob: e21d17c055def402e2528ee595b0541dd584ae09 [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001# Common code for dbus applications using c.
2
3inherit obmc-phosphor-systemd
4inherit obmc-phosphor-license
5
6DEPENDS += "glib-2.0"
7SRC_URI += " \
8 file://Makefile \
9 file://${PN}.c \
10 "
11S = "${WORKDIR}"
12
13do_install_append() {
14 # install the binary
15 install -d ${D}${sbindir}
16 install -m 0755 ${WORKDIR}/${PN} ${D}${sbindir}
17}