blob: 4f556294bc599078c462388f3484141f0b6e72c8 [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001# Helper functions for checking feature variables.
2
3inherit utils
4
5def df_enabled(feature, value, d):
6 return base_contains("DISTRO_FEATURES", feature, value, "", d)
7
8def mf_enabled(feature, value, d):
9 return base_contains("MACHINE_FEATURES", feature, value, "", d)
10
11def cf_enabled(feature, value, d):
12 return value if df_enabled(feature, value, d) \
13 and mf_enabled(feature, value, d) \
14 else ""