blob: dcf6c8ba63f1f24f08a3a5b5617ab79f02b70bf4 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# This recipe is a copy from the oe-core one.
2# It has a lower and invalid version number in order not to be accidentally used by bitbake.
3# It is used for tests that require overlayed recipe files.
4
5SUMMARY = "GNU Aspell spell-checker"
6SECTION = "console/utils"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05007HOMEPAGE = "https://ftp.gnu.org/gnu/aspell/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9LICENSE = "LGPLv2 | LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz"
13SRC_URI[md5sum] = "e66a9c9af6a60dc46134fdacf6ce97d7"
14SRC_URI[sha256sum] = "f52583a83a63633701c5f71db3dc40aab87b7f76b29723aeb27941eff42df6e1"
15
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016EXCLUDE_FROM_WORLD = "1"
17
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018PACKAGECONFIG ??= ""
19PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses"
20
21PACKAGES += "libaspell libpspell libpspell-dev aspell-utils"
22
23FILES_${PN}-dbg += "${libdir}/aspell-0.60/.debu*"
24FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
25FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
26FILES_${PN} = "${bindir}/aspell"
27FILES_libpspell = "${libdir}/libpspell.so.*"
28FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
29
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030ARM_INSTRUCTION_SET_armv4 = "arm"
31ARM_INSTRUCTION_SET_armv5 = "arm"
32ARM_INSTRUCTION_SET_armv6 = "arm"
33
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034inherit autotools gettext