blob: 7ace901cc3ac120d5fa9863407bfb5255a054caf [file] [log] [blame]
Andrew Geissler95ac1b82021-03-31 14:34:31 -05001SUMMARY = "Sysroot poisoning test"
2LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
3
4LICENSE = "MIT"
5
6inherit nopackages
7
8# This test confirms that compiling code that searches /usr/include for headers
9# will result in compiler errors. This recipe should will fail to build and
10# oe-selftest has a test that verifies that.
11do_compile() {
12 touch empty.c
13 ${CPP} ${CFLAGS} -I/usr/include empty.c
14}
15
16EXCLUDE_FROM_WORLD = "1"