blob: d81f68bd2e83017e38f3e52cc4d0790e061ee6e5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Common code for generating core reference images
2#
3# Copyright (C) 2007-2011 Linux Foundation
4
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005# IMAGE_FEATURES control content of the core reference images
6#
7# By default we install packagegroup-core-boot and packagegroup-base-extended packages;
8# this gives us working (console only) rootfs.
9#
10# Available IMAGE_FEATURES:
11#
Andrew Geissler95ac1b82021-03-31 14:34:31 -050012# - weston - Weston Wayland compositor
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013# - x11 - X server
14# - x11-base - X server with minimal environment
15# - x11-sato - OpenedHand Sato environment
16# - tools-debug - debugging tools
17# - eclipse-debug - Eclipse remote debugging support
18# - tools-profile - profiling tools
19# - tools-testapps - tools usable to make some device tests
20# - tools-sdk - SDK (C/C++ compiler, autotools, etc.)
21# - nfs-server - NFS server
22# - nfs-client - NFS client
23# - ssh-server-dropbear - SSH server (dropbear)
24# - ssh-server-openssh - SSH server (openssh)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025# - hwcodecs - Install hardware acceleration codecs
26# - package-management - installs package management tools and preserves the package manager database
27# - debug-tweaks - makes an image suitable for development, e.g. allowing passwordless root logins
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028# - empty-root-password
29# - allow-empty-password
Andrew Geissler82c905d2020-04-13 13:39:40 -050030# - allow-root-login
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031# - post-install-logging
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032# - dev-pkgs - development packages (headers, etc.) for all installed packages in the rootfs
33# - dbg-pkgs - debug symbol packages for all installed packages in the rootfs
34# - doc-pkgs - documentation packages for all installed packages in the rootfs
Brad Bishop00e122a2019-10-05 11:10:57 -040035# - bash-completion-pkgs - bash-completion packages for recipes using bash-completion bbclass
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036# - ptest-pkgs - ptest packages for all ptest-enabled recipes
37# - read-only-rootfs - tweaks an image to support read-only rootfs
Andrew Geissler82c905d2020-04-13 13:39:40 -050038# - stateless-rootfs - systemctl-native not run, image populated by systemd at runtime
Brad Bishop6e60e8b2018-02-01 10:27:11 -050039# - splash - bootup splash screen
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040#
Andrew Geissler95ac1b82021-03-31 14:34:31 -050041FEATURE_PACKAGES_weston = "packagegroup-core-weston"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042FEATURE_PACKAGES_x11 = "packagegroup-core-x11"
43FEATURE_PACKAGES_x11-base = "packagegroup-core-x11-base"
44FEATURE_PACKAGES_x11-sato = "packagegroup-core-x11-sato"
45FEATURE_PACKAGES_tools-debug = "packagegroup-core-tools-debug"
46FEATURE_PACKAGES_eclipse-debug = "packagegroup-core-eclipse-debug"
47FEATURE_PACKAGES_tools-profile = "packagegroup-core-tools-profile"
48FEATURE_PACKAGES_tools-testapps = "packagegroup-core-tools-testapps"
49FEATURE_PACKAGES_tools-sdk = "packagegroup-core-sdk packagegroup-core-standalone-sdk-target"
50FEATURE_PACKAGES_nfs-server = "packagegroup-core-nfs-server"
51FEATURE_PACKAGES_nfs-client = "packagegroup-core-nfs-client"
52FEATURE_PACKAGES_ssh-server-dropbear = "packagegroup-core-ssh-dropbear"
53FEATURE_PACKAGES_ssh-server-openssh = "packagegroup-core-ssh-openssh"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054FEATURE_PACKAGES_hwcodecs = "${MACHINE_HWCODECS}"
55
56
57# IMAGE_FEATURES_REPLACES_foo = 'bar1 bar2'
58# Including image feature foo would replace the image features bar1 and bar2
59IMAGE_FEATURES_REPLACES_ssh-server-openssh = "ssh-server-dropbear"
60
61# IMAGE_FEATURES_CONFLICTS_foo = 'bar1 bar2'
62# An error exception would be raised if both image features foo and bar1(or bar2) are included
63
64MACHINE_HWCODECS ??= ""
65
66CORE_IMAGE_BASE_INSTALL = '\
67 packagegroup-core-boot \
68 packagegroup-base-extended \
69 \
70 ${CORE_IMAGE_EXTRA_INSTALL} \
71 '
72
73CORE_IMAGE_EXTRA_INSTALL ?= ""
74
75IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}"
76
77inherit image