blob: d221cbcd7f12d41c2ec8a0939c34c418349d4cce [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001SUMMARY = "Simple powerful testing with python"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05002HOMEPAGE = "https://pypi.org/project/pytest/"
3DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b"
7
8SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch "
9
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060010SRC_URI[sha256sum] = "9d1edf9e7d0b84d72ea3dbcdfd22b35fb543a5e8f2a60092dd578936bf63d7f9"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060011
12inherit update-alternatives pypi setuptools3
13
14RDEPENDS_${PN}_class-target += " \
15 ${PYTHON_PN}-atomicwrites \
16 ${PYTHON_PN}-attrs \
17 ${PYTHON_PN}-debugger \
18 ${PYTHON_PN}-doctest \
19 ${PYTHON_PN}-importlib-metadata \
20 ${PYTHON_PN}-iniconfig \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-more-itertools \
23 ${PYTHON_PN}-packaging \
24 ${PYTHON_PN}-pathlib2 \
25 ${PYTHON_PN}-pluggy \
26 ${PYTHON_PN}-py \
27 ${PYTHON_PN}-setuptools \
28 ${PYTHON_PN}-six \
29 ${PYTHON_PN}-toml \
30 ${PYTHON_PN}-wcwidth \
31"
32
33ALTERNATIVE_${PN} += "py.test pytest"
34
35NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
36ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
37
38ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
39ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
40
41BBCLASSEXTEND = "native nativesdk"