blob: 12122131a5df37d7ca6a603306c68addf914925f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Software Construction tool (make/autotools replacement)"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05002HOMEPAGE = "https://github.com/SCons/scons"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE-python3-scons-${PV};md5=e14e1b33428df24a40a782ae142785d0"
6
7# pypi package does not have a valid license file
8SRC_URI += "https://raw.githubusercontent.com/SCons/scons/${PV}/LICENSE;downloadfilename=LICENSE-python3-scons-${PV};name=license"
9
10SRC_URI[md5sum] = "f9c4ad06dcf1427be95472eaf380c81a"
11SRC_URI[sha256sum] = "8aaa483c303efeb678e6f7c776c8444a482f8ddc3ad891f8b6cdd35264da9a1f"
12SRC_URI[license.md5sum] = "e14e1b33428df24a40a782ae142785d0"
13SRC_URI[license.sha256sum] = "72ed889165fb28378cadac14552be4a959f1ebab6b148abb5dd2b49712c3c6f6"
14
15S = "${WORKDIR}/scons-${PV}"
16
17UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html"
18UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
19
20inherit pypi setuptools3
21
22do_install_prepend() {
23 sed -i -e "1s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/script/*
24}
25
26RDEPENDS_${PN}_class-target = "\
27 python3-core \
28 python3-fcntl \
29 python3-io \
30 python3-json \
31 python3-shell \
32 python3-pickle \
33 python3-pprint \
34 "