blob: f58ca2eb2cb6c47776eb5199fad2c2b6350eb16f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15"
16
17DEPENDS = "attr libaio libcap acl openssl zip-native"
18DEPENDS_append_libc-musl = " fts "
19EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
20EXTRA_OECONF_append_libc-musl = " LIBS=-lfts "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060030SRCREV = "4d005621edd109d119627eb9210b224a63bf22cb"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
Andrew Geissler90fd73c2021-03-05 15:25:55 -060032# remove at next version upgrade or when output changes
Andrew Geissler95ac1b82021-03-31 14:34:31 -050033PR = "r4"
34HASHEQUIV_HASH_VERSION .= ".4"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060035
Andrew Geissler82c905d2020-04-13 13:39:40 -050036SRC_URI = "git://github.com/linux-test-project/ltp.git \
37 file://0001-build-Add-option-to-select-libc-implementation.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050038 file://0007-Fix-test_proc_kill-hanging.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050039 file://0001-Add-more-musl-exclusions.patch \
Andrew Geissler635e0e42020-08-21 15:58:33 -050040 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060041 file://determinism.patch \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050042 file://0001-open_posix_testsuite-generate-makefiles.sh-Avoid-inc.patch \
43 file://0002-Makefile-Avoid-wildcard-determinism-issues.patch \
44 file://0003-syscalls-swapon-swapoff-Move-common-library-to-libs.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050045 "
46
47S = "${WORKDIR}/git"
48
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050049inherit autotools-brokensep pkgconfig
Andrew Geissler82c905d2020-04-13 13:39:40 -050050
51TARGET_CC_ARCH += "${LDFLAGS}"
52
53export prefix = "/opt/${PN}"
54export exec_prefix = "/opt/${PN}"
55
56PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
57EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
Andrew Geissler635e0e42020-08-21 15:58:33 -050058EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
Andrew Geissler82c905d2020-04-13 13:39:40 -050059# ltp network/rpc test cases ftbfs when libtirpc is found
60EXTRA_OECONF += " --without-tirpc "
61
62do_install(){
63 install -d ${D}${prefix}/
64 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
65
66 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
67 # as it lacks dependency on some perl moudle such as LWP::Simple
68 # And this script previously works as a tool for analyzing failures from LTP
69 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
70 # http://khack.osdl.org to retrieve ltp test results run on
71 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
72 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
73
74 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
75 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
76
77 # Makefile were configured in the build system
78 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
79 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
80 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
81 -e 's@[^ ]*--sysroot=[^ "]*@@g'
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050082
83 # The controllers memcg_stree test seems to cause us hangs and takes 900s
84 # (maybe we expect more regular output?), anyhow, skip it
85 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler82c905d2020-04-13 13:39:40 -050086}
87
88RDEPENDS_${PN} = "\
89 attr \
90 bash \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050091 bc \
92 coreutils \
Andrew Geissler82c905d2020-04-13 13:39:40 -050093 cpio \
94 cronie \
95 curl \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050096 e2fsprogs \
Andrew Geissler82c905d2020-04-13 13:39:40 -050097 e2fsprogs-mke2fs \
98 expect \
99 file \
100 gawk \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500101 gdb \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500102 gzip \
103 iproute2 \
104 ldd \
105 libaio \
106 logrotate \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500107 net-tools \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500108 perl \
109 python3-core \
110 procps \
111 quota \
112 unzip \
113 util-linux \
114 which \
115 tar \
116"
117
118FILES_${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
119
120# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
121INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
122INSANE_SKIP_${PN} += "already-stripped staticdev"
123
124# Avoid file dependency scans, as LTP checks for things that may or may not
125# exist on the running system. For instance it has specific checks for
126# csh and ksh which are not typically part of OpenEmbedded systems (but
127# can be added via additional layers.)
128SKIP_FILEDEPS_${PN} = '1'