blob: 7dcfd6733b9570db5f937f90e795807ebac093a4 [file] [log] [blame]
Andrew Geissler95ac1b82021-03-31 14:34:31 -05001SUMMARY = "Basic Weston compositor setup"
2DESCRIPTION = "Packages required to set up a basic working Weston session"
3PR = "r1"
4
5inherit packagegroup features_check
6
7# weston-init requires pam enabled if started via systemd
8REQUIRED_DISTRO_FEATURES = "wayland ${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', 'pam', '', d)}"
9
10RDEPENDS_${PN} = "\
11 weston \
12 weston-init \
13 weston-examples \
14 wayland-utils \
15 "