blob: 59c2003b74ebbc05afc6b2f9cbcb2d1e2bb8b2c8 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Real-time file compressor"
2DESCRIPTION = "lzop is a compression utility which is designed to be a companion to gzip. \n\
3It is based on the LZO data compression library and its main advantages over \n\
4gzip are much higher compression and decompression speed at the cost of some \n\
5compression ratio. The lzop compression utility was designed with the goals \n\
6of reliability, speed, portability and with reasonable drop-in compatibility \n\
7to gzip."
Andrew Geissler95ac1b82021-03-31 14:34:31 -05008HOMEPAGE = "http://www.lzop.org/"
Brad Bishop19323692019-04-05 15:28:33 -04009DEPENDS += "lzo"
10
11LICENSE = "GPLv2+"
12LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13 file://src/lzop.c;beginline=5;endline=21;md5=23d767de7754eb24b9e900b025cf7fc8"
14
15SRC_URI = "http://www.lzop.org/download/${BP}.tar.gz \
16 file://acinclude.m4 \
17 "
18SRC_URI[md5sum] = "271eb10fde77a0a96b9cbf745e719ddf"
19SRC_URI[sha256sum] = "7e72b62a8a60aff5200a047eea0773a8fb205caf7acbe1774d95147f305a2f41"
20
21inherit autotools
22
23do_configure_prepend () {
24 install -Dm 0644 ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
25}
26
27BBCLASSEXTEND = "native nativesdk"