blob: 9e38872361b2169441b736cf53d136a29fde9337 [file] [log] [blame]
Andrew Geissler95ac1b82021-03-31 14:34:31 -05001SUMMARY = "Extremely fast non-cryptographic hash algorithm"
2DESCRIPTION = "xxHash is an extremely fast non-cryptographic hash algorithm, \
3working at speeds close to RAM limits."
4HOMEPAGE = "http://www.xxhash.com/"
5LICENSE = "BSD-2-Clause & GPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b335320506abb0505437e39295e799cb"
7
8SRC_URI = "git://github.com/Cyan4973/xxHash.git;branch=release;protocol=git"
9UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
10
11SRCREV = "94e5f23e736f2bb67ebdf90727353e65344f9fc0"
12
13S = "${WORKDIR}/git"
14
15do_compile () {
16 oe_runmake all
17}
18
19do_install () {
20 oe_runmake DESTDIR=${D} install
21}
22
23BBCLASSEXTEND = "native nativesdk"