blob: 2dd76c93b7b6f8d190859171c827f5a87178b9e2 [file] [log] [blame]
Konstantin Aladyshev19abd962023-02-09 12:21:32 +03001DESCRIPTION = "Transfer BMC IP address to the FPGA"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit systemd
7
8SRC_URI = " file://ip-to-fpga.sh \
9 file://ip-to-fpga.service \
10 "
11
12S = "${WORKDIR}"
13
14DEPENDS = "systemd"
15RDEPENDS:${PN} = "bash"
16
17SYSTEMD_SERVICE:${PN} = "ip-to-fpga.service"
18
19do_install() {
20 install -d ${D}${bindir}
21 install -m 0755 ${S}/ip-to-fpga.sh ${D}${bindir}/
22
23 install -d ${D}${systemd_system_unitdir}
24 install -m 0644 ${S}/ip-to-fpga.service ${D}${systemd_system_unitdir}
25}