Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools for managing Yocto Project style branched kernels" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Powerful set of tools or managing Yocto Linux kernel sources \ |
| 3 | and configuration data. You can use these tools to make a single configuration \ |
| 4 | change, apply multiple patches, or work with your own kernel sources." |
| 5 | HOMEPAGE = "https://www.yoctoproject.org/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | LICENSE = "GPLv2" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://tools/kgit;beginline=5;endline=9;md5=9c30e971d435e249624278c3e343e501" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | |
| 9 | DEPENDS = "git-native" |
| 10 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 11 | SRCREV = "d220b063852245fdd16b9731a395ace525f932d6" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | PR = "r12" |
| 13 | PV = "0.2+git${SRCPV}" |
| 14 | |
| 15 | inherit native |
| 16 | |
| 17 | SRC_URI = "git://git.yoctoproject.org/yocto-kernel-tools.git" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | UPSTREAM_CHECK_COMMITS = "1" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | do_configure() { |
| 22 | : |
| 23 | } |
| 24 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | do_compile() { |
| 26 | : |
| 27 | } |
| 28 | |
| 29 | do_install() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | oe_runmake DESTDIR=${D}${bindir} install |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 31 | } |