blob: 37f774684647d7fda8bfc9684b26c9a3c38f0a3a [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Gstreamer editing services"
5HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-editing-services/"
6
7LICENSE = "GPL-2.0-on-later & LGPL-2.1-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
9 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d"
10
11DEPENDS = "flex-native gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad python3-pygobject"
12
13REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
14GIR_MESON_OPTION = ""
15
16inherit meson pkgconfig upstream-version-is-even gobject-introspection features_check bash-completion
17
18EXTRA_OEMESON = "-Dvalidate=disabled"
19
20SRC_URI = "http://gstreamer.freedesktop.org/src/gst-editing-services/gst-editing-services-${PV}.tar.xz"
Patrick Williams975a06f2022-10-21 14:42:47 -050021SRC_URI[sha256sum] = "aa03e983af5d79c1befffe3575b034e60960619a96bf877447cb73c28016fc41"
Patrick Williams92b42cb2022-09-03 06:53:57 -050022
23PACKAGES += "gst-validate-launcher libges"
24
25FILES:gst-validate-launcher = "${nonarch_libdir}/gst-validate-launcher ${datadir}/gstreamer-1.0/validate"
26FILES:libges = "${libdir}/gstreamer-1.0/*.so"