blob: 8292419473643656b55d136c5960d13059fe0e7c [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A fully featured modbus protocol stack in python"
2HOMEPAGE = "https://github.com/riptideio/pymodbus/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=2c2223d66c7e674b40527b5a4c35bd76"
5DEPENDS += "python3-six-native"
6
Patrick Williams975a06f2022-10-21 14:42:47 -05007SRC_URI[sha256sum] = "37c9b6f3e5c82f39ee42047ca48cbc9fd0c49a6731126789500191e9deea6cbc"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008S = "${WORKDIR}/pymodbus-${PV}"
9
10inherit pypi setuptools3
11
12PACKAGECONFIG ??= ""
13PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio"
14PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio"
15PACKAGECONFIG[tornado] = ",,,python3-tornado"
16PACKAGECONFIG[twisted] = ",,,python3-twisted-conch"
17PACKAGECONFIG[redis] = ",,,python3-redis"
18PACKAGECONFIG[sql] = ",,,python3-sqlalchemy"
19
20RDEPENDS:${PN} += " \
21 python3-asyncio \
22 python3-core \
23 python3-io \
24 python3-json \
25 python3-logging \
26 python3-math \
27 python3-netserver \
28"
29
30RDEPENDS:${PN} += " \
31 python3-pyserial \
32 python3-six \
33"
34
35