blob: 2c137f6ce7c11776fd516283b718f5f4afd4e1c4 [file] [log] [blame]
Andrew Geissler97771a32021-03-05 15:23:11 -06001DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7DEPENDS += "${PYTHON_PN}-protobuf"
8
9SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
10SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \
11 file://riscv64_support.patch \
12 file://boring_ssl.patch \
13"
14SRC_URI[sha256sum] = "7bd0ebbb14dde78bf66a1162efd29d3393e4e943952e2f339757aa48a184645c"
15
16RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
17 ${PYTHON_PN}-setuptools \
18 ${PYTHON_PN}-six \
19"
20
21inherit setuptools3
22inherit pypi
23
24export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1"
25
26BORING_SSL_PLATFORM_arm = "linux-arm"
27BORING_SSL_PLATFORM_x86-64 = "linux-x86_64"
28BORING_SSL_PLATFORM ?= "unsupported"
29export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}"
30
31BORING_SSL_x86-64 = "1"
32BORING_SSL_arm = "1"
33BORING_SSL ?= "0"
34export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}"
35
36GRPC_CFLAGS_append_toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions"
37export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}"
38
39CLEANBROKEN = "1"
40
41BBCLASSEXTEND = "native nativesdk"
42
43CCACHE_DISABLE = "1"