blob: e98e13cd17a506f6e7b0e17964d7e0b0c16b7ab0 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001require recipes-devtools/atp/atp-source_3.1.inc
Brad Bishopbec4ebc2022-08-03 09:55:16 -04002
3SUMMARY = "End-to-end tests evaluating ATP kernel modules service correctness"
4SECTION = "kernel/userland"
5
6S = "${WORKDIR}/git"
7SRC_URI = "${ATP_SRC}"
8
9EXTRA_OEMAKE += "-C linux/test"
10
11do_compile() {
12 oe_runmake
13}
14
15do_install() {
16 oe_runmake DESTDIR=${D} PREFIX=${prefix} install
17}
18
19DEPENDS = "atp-uapi cppunit"
20RDEPENDS:${PN} = "atp-uapi"