blob: e4b97e948f3e60c157d8ecde361949d63d578de6 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001# Use OVERRIDES to minimize the usage of
2# ${@bb.utils.contains('DISTRO_FEATURES', 'xen', ...
3OVERRIDES:append = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ':xen', '', d)}"
4
5# Xen image to put in the image
6# This should point to a file in the deploy image directory
7BOOT_WRAPPER_AARCH64_XEN ??= "xen-${MACHINE}"
8
9# Xen command line for the image
10BOOT_WRAPPER_AARCH64_XEN_CMDLINE ??= "noreboot dom0_mem=256M"
11
12BOOT_WRAPPER_AARCH64_XEN_CMDLINE:gem5-arm64 = "noreboot dom0_mem=256M console=dtuart \
13 dtuart=/uart@1c090000 bootscrub=0"
14
15# Fix command line in the axf file for gem5-arm64 when Xen is present
16BOOT_WRAPPER_AARCH64_CMDLINE_xen:gem5-arm64 = "console=hvc0 root=/dev/vda rw"
17
18# Image generated by boot wrapper when Xen is present
19BOOT_WRAPPER_AARCH64_IMAGE:xen ?= "xen-system.axf"
20
21EXTRA_OECONF:append:xen = " \
22--with-xen=${WORKDIR}/kernel/arch/arm64/boot/Image \
23--with-xen-cmdline="" \
24"
25
26EXTRA_OEMAKE:append:xen = " \
27XEN_IMAGE=${DEPLOY_DIR_IMAGE}/${BOOT_WRAPPER_AARCH64_XEN} \
28XEN_CMDLINE="${BOOT_WRAPPER_AARCH64_XEN_CMDLINE}" \
29"
30
31# We need xen if it is activated
32do_deploy[depends] += "${@bb.utils.contains('DISTRO_FEATURES', 'xen', 'xen:do_deploy', '', d)}"