blob: b91dbbc72b2663afec15afe37c59fb2c142e7e49 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001require gem5-source_20.inc
2
3SUMMARY = "m5term allows users to connect to gem5's simulated console"
4HOMEPAGE = "https://www.gem5.org/documentation/general_docs/fullsystem/m5term"
5LICENSE = "BSD-3-Clause"
6
7inherit native
8
9M5TERM_DIR = "util/term"
10
11SRC_URI += "file://0001-add-makefile-flags.patch"
12
13do_compile() {
14 oe_runmake -C ${S}/${M5TERM_DIR}
15}
16
17# The Makefile for m5term does not provide a "install" target
18# We do the install process within the recipe
19do_install() {
20 install -d ${D}${bindir}
21 install -m 755 ${B}/${M5TERM_DIR}/m5term ${D}${bindir}
22}
23
24addtask addto_recipe_sysroot before do_build