blob: 13d3e0af799d99a963f756421083ba6ace1b1b8d [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "GNOME editor"
2SECTION = "x11/gnome"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8DEPENDS = " \
9 gdk-pixbuf-native \
10 gtk+3 \
11 gsettings-desktop-schemas \
12 libpeas \
13 libsoup-2.4 \
14 gspell \
15 gtksourceview4 \
16 tepl \
17"
18
19inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc vala gettext features_check mime-xdg python3targetconfig
20
21def gnome_verdir(v):
22 return oe.utils.trim_version(v, 1)
23
24SRC_URI[archive.sha256sum] = "3c6229111f0ac066ae44964920791d1265f5bbb56b0bd949a69b7b1261fc8fca"
25
26# gobject-introspection is mandatory and cannot be configured
27REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
28ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
29
30GIR_MESON_OPTION = ""
31
32GTKDOC_MESON_OPTION = "gtk_doc"
33
34PACKAGES += "${PN}-python"
35
36FILES:${PN} += " \
37 ${datadir}/dbus-1 \
38 ${datadir}/metainfo \
39"
40
41FILES:${PN}-python += " \
42 ${PYTHON_SITEPACKAGES_DIR} \
43"
44
45RDEPENDS:${PN} += "gsettings-desktop-schemas"
46RRECOMMENDS:${PN} += "source-code-pro-fonts"