blob: 7ceb26d7a2a3f5d6ddb97aa2636bdbd898c2ba39 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Grilo is a framework forsearching media content from various sources"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "LGPL-2.1-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4
5DEPENDS = " \
6 libxml2 \
7 glib-2.0 \
8"
9
10GNOMEBASEBUILDCLASS = "meson"
11
12inherit gnomebase gobject-introspection gtk-doc gettext vala
13
14SRC_URI[archive.sha256sum] = "0369d0b00bb0f59ba5f7aea8cfc665f38df14a5b4182d28c7c1e2cd15b518743"
15
16GIR_MESON_OPTION = "enable-introspection"
17GTKDOC_MESON_OPTION = "enable-gtk-doc"
18
19# Note: removing 'net' from PACKAGECONFIG causes
20# | bindings/vala/meson.build:15:0: ERROR: Unknown variable "grlnet_gir".
21PACKAGECONFIG ??= "net"
22
23PACKAGECONFIG[net] = "-Denable-grl-net=true, -Denable-grl-net=false, libsoup-2.4"
24PACKAGECONFIG[test-ui] = "-Denable-test-ui=true, -Denable-test-ui=false, gtk+3 liboauth"
25
26# Once we have a recipe for 'totem-plparser' this can turn into a PACKAGECONFIG
27EXTRA_OEMESON = "-Denable-grl-pls=false"
28