blob: a0f928ce254442f2c84c0752e08adf3e96ede02c [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "File manager for GNOME"
2SECTION = "x11/gnome"
3
4LICENSE="GPL-3.0-only"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
6
7GNOMEBASEBUILDCLASS = "meson"
8
9DEPENDS = " \
10 fontconfig \
11 gtk+3 \
12 gnome-desktop \
13 gsettings-desktop-schemas \
14 gnome-autoar \
15 tracker \
16 libhandy \
Andrew Geissler9aee5002022-03-30 16:27:02 +000017"
18
19inherit gnomebase gsettings gobject-introspection gtk-doc gettext features_check mime-xdg
20
21def gnome_verdir(v):
22 return oe.utils.trim_version(v, 1)
23
Andrew Geissler87f5cff2022-09-30 13:13:31 -050024SRC_URI += " file://0001-Provide-parameter-prototype-for-functions-without-pa.patch"
Andrew Geissler615f2f12022-07-15 14:00:58 -050025SRC_URI[archive.sha256sum] = "99212d2eb75996f181728ad04a2e2d86f2577b064e68a34c8b81a7037df4ccb2"
Andrew Geissler9aee5002022-03-30 16:27:02 +000026
27REQUIRED_DISTRO_FEATURES = "x11"
28
29EXTRA_OEMESON += " \
30 -Dtests=none \
31"
32
33PACKAGECONFIG = "extensions"
34PACKAGECONFIG[extensions] = "-Dextensions=true,-Dextensions=false, gexiv2 gstreamer1.0-plugins-base"
Patrick Williams45852732022-04-02 08:58:32 -050035PACKAGECONFIG[libportal] = "-Dlibportal=true,-Dlibportal=false, libportal"
Andrew Geissler9aee5002022-03-30 16:27:02 +000036
37FILES:${PN} += " \
38 ${datadir}/dbus-1 \
39 ${datadir}/metainfo \
40 ${datadir}/gnome-shell \
41 ${datadir}/tracker3 \
42"
43
44# mandatory - not checked during configuration:
45# | (org.gnome.Nautilus:863): GLib-GIO-ERROR **: 21:03:52.326: Settings schema 'org.freedesktop.Tracker.Miner.Files' is not installed
46RDEPENDS:${PN} += "tracker-miners"