blob: 757c88c9565517ae7a4f95748206e02a67e45270 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Multimedia processing server for Linux"
2DESCRIPTION = "Linux server for handling and routing audio and video streams between applications and multimedia I/O devices"
3HOMEPAGE = "https://pipewire.org/"
4BUGTRACKER = "https://gitlab.freedesktop.org/pipewire/pipewire/issues"
5AUTHOR = "Wim Taymans <wtaymans@redhat.com>"
6SECTION = "multimedia"
7
8LICENSE = "MIT & LGPL-2.1-or-later & GPL-2.0-only"
9LIC_FILES_CHKSUM = " \
10 file://LICENSE;md5=2158739e172e58dc9ab1bdd2d6ec9c72 \
11 file://COPYING;md5=97be96ca4fab23e9657ffa590b931c1a \
12"
13
14DEPENDS = "dbus ncurses"
15
Patrick Williams975a06f2022-10-21 14:42:47 -050016SRCREV = "f54a72fd9a67eeb8d1502d6d75979dbddb00fdf2"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050017SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https"
Patrick Williams92b42cb2022-09-03 06:53:57 -050018
19S = "${WORKDIR}/git"
20
21inherit meson pkgconfig systemd gettext useradd
22
23USERADD_PACKAGES = "${PN}"
24
25GROUPADD_PARAM:${PN} = "--system pipewire"
26
27USERADD_PARAM:${PN} = "--system --home / --no-create-home \
28 --comment 'PipeWire multimedia daemon' \
29 --gid pipewire --groups audio,video \
30 pipewire"
31
32SYSTEMD_PACKAGES = "${PN}"
33
34# For "EVL", look up https://evlproject.org/ . It involves
35# a specially prepared kernel, and is currently unavailable
36# in Yocto.
37#
38# Vulkan support is currently (as of version 0.3.44) not functional.
39#
40# manpage generation requires xmltoman, which is not available.
41#
42# The session-managers list specifies which session managers Meson
43# shall download (via git clone) and build as subprojects. In OE,
44# this is not how a session manager should be built. Instead, they
45# should be integrated as separate OE recipes. To prevent PipeWire
46# from using this Meson feature, set an empty list.
47# This does not disable support or the need for session managers,
48# it just prevents this subproject feature.
49#
50# AptX and LDAC are not available in OE. Currently, neither
51# are lv2 and ROC.
52#
53# The RTKit module is deprecated in favor of the newer RT module.
54# It still exists for legacy setups that still include it in
55# their PipeWire configuration files.
56EXTRA_OEMESON += " \
57 -Devl=disabled \
58 -Dtests=disabled \
59 -Dudevrulesdir=${nonarch_base_libdir}/udev/rules.d/ \
60 -Dsystemd-system-unit-dir=${systemd_system_unitdir} \
61 -Dsystemd-user-unit-dir=${systemd_user_unitdir} \
62 -Dman=disabled \
63 -Dsession-managers='[]' \
64 -Dlv2=disabled \
65 -Droc=disabled \
66 -Dbluez5-codec-aptx=disabled \
67 -Dbluez5-codec-ldac=disabled \
68 -Dlegacy-rtkit=false \
69"
70
71# spa alsa plugin code uses typedef redefinition, which is officially a C11 feature.
72# Pipewire builds with 'c_std=gnu99' by default. Recent versions of gcc don't issue this warning in gnu99
73# mode but it looks like clang still does
74CFLAGS:append = " -Wno-typedef-redefinition"
75
76# According to wireplumber documentation only one session manager should be installed at a time
77# Possible options are media-session, which has fewer dependencies but is very simple,
78# or wireplumber, which is more powerful.
79PIPEWIRE_SESSION_MANAGER ??= "media-session"
80
81FFMPEG_AVAILABLE = "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'ffmpeg', '', d)}"
82BLUETOOTH_AAC = "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'bluez-aac', '', d)}"
83
84PACKAGECONFIG:class-target ??= " \
85 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050086 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez bluez-opus ${BLUETOOTH_AAC}', '', d)} \
Patrick Williams92b42cb2022-09-03 06:53:57 -050087 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd systemd-system-service systemd-user-service', '', d)} \
88 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa vulkan pulseaudio', d)} \
89 ${PIPEWIRE_SESSION_MANAGER} \
90 ${FFMPEG_AVAILABLE} gstreamer jack libusb pw-cat raop sndfile v4l2 udev volume \
91"
92
93# "jack" and "pipewire-jack" packageconfigs cannot be both enabled,
94# since "jack" imports libjack, and "pipewire-jack" generates
95# libjack.so* files, thus colliding with the libpack package. This
96# is why these two are marked in their respective packageconfigs
97# as being in conflict.
98PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib udev,,pipewire-alsa pipewire-alsa-card-profile"
99PACKAGECONFIG[avahi] = "-Davahi=enabled,-Davahi=disabled,avahi"
100PACKAGECONFIG[bluez] = "-Dbluez5=enabled,-Dbluez5=disabled,bluez5 sbc"
101PACKAGECONFIG[bluez-aac] = "-Dbluez5-codec-aac=enabled,-Dbluez5-codec-aac=disabled,fdk-aac"
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500102PACKAGECONFIG[bluez-opus] = "-Dbluez5-codec-opus=enabled,-Dbluez5-codec-opus=disabled,libopus"
Patrick Williams92b42cb2022-09-03 06:53:57 -0500103PACKAGECONFIG[docs] = "-Ddocs=enabled,-Ddocs=disabled,doxygen-native graphviz-native"
104PACKAGECONFIG[ffmpeg] = "-Dffmpeg=enabled,-Dffmpeg=disabled,ffmpeg"
105PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base,,gstreamer1.0-pipewire"
106PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack,,,pipewire-jack"
107PACKAGECONFIG[libcamera] = "-Dlibcamera=enabled,-Dlibcamera=disabled,libcamera libdrm"
108PACKAGECONFIG[libcanberra] = "-Dlibcanberra=enabled,-Dlibcanberra=disabled,libcanberra"
109PACKAGECONFIG[libusb] = "-Dlibusb=enabled,-Dlibusb=disabled,libusb"
110PACKAGECONFIG[media-session] = ",,,pipewire-media-session,,wireplumber"
111PACKAGECONFIG[pulseaudio] = "-Dlibpulse=enabled,-Dlibpulse=disabled,pulseaudio,,pipewire-pulse"
112PACKAGECONFIG[pipewire-alsa] = "-Dpipewire-alsa=enabled,-Dpipewire-alsa=disabled,alsa-lib"
113PACKAGECONFIG[pipewire-jack] = "-Dpipewire-jack=enabled -Dlibjack-path=${libdir}/${PW_MODULE_SUBDIR}/jack,-Dpipewire-jack=disabled,jack,,pipewire-jack,jack"
114PACKAGECONFIG[pw-cat] = "-Dpw-cat=enabled,-Dpw-cat=disabled"
115PACKAGECONFIG[raop] = "-Draop=enabled,-Draop=disabled,openssl"
116PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,libsdl2"
117PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1"
118PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd"
119PACKAGECONFIG[systemd-system-service] = "-Dsystemd-system-service=enabled,-Dsystemd-system-service=disabled,systemd"
120# "systemd-user-service" packageconfig will only install service
121# files to rootfs but not enable them as systemd.bbclass
122# currently lacks the feature of enabling user services.
123PACKAGECONFIG[systemd-user-service] = "-Dsystemd-user-service=enabled,-Dsystemd-user-service=disabled,systemd"
124# pw-cat needs sndfile packageconfig to be enabled
125PACKAGECONFIG[udev] = "-Dudev=enabled,-Dudev=disabled,udev"
126PACKAGECONFIG[v4l2] = "-Dv4l2=enabled,-Dv4l2=disabled,udev"
127PACKAGECONFIG[volume] = "-Dvolume=enabled,-Dvolume=disabled"
128PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-headers vulkan-loader"
129PACKAGECONFIG[webrtc-echo-cancelling] = "-Decho-cancel-webrtc=enabled,-Decho-cancel-webrtc=disabled,webrtc-audio-processing"
130PACKAGECONFIG[wireplumber] = ",,,wireplumber,,media-session"
131
132PACKAGESPLITFUNCS:prepend = " split_dynamic_packages "
133PACKAGESPLITFUNCS:append = " set_dynamic_metapkg_rdepends "
134
135SPA_SUBDIR = "spa-0.2"
136PW_MODULE_SUBDIR = "pipewire-0.3"
137
138remove_unused_installed_files() {
139 # jack.conf is used by pipewire-jack (not the JACK SPA plugin).
140 # Remove it if pipewire-jack is not built to avoid creating the
141 # pipewire-jack package.
142 if ${@bb.utils.contains('PACKAGECONFIG', 'pipewire-jack', 'false', 'true', d)}; then
143 rm -f "${D}${datadir}/pipewire/jack.conf"
144 fi
145
146 # minimal.conf is an example of how to minimally configure the
147 # daemon and is not meant to be used for production.
148 rm -f "${D}${datadir}/pipewire/minimal.conf"
149}
150
151do_install[postfuncs] += "remove_unused_installed_files"
152
153python split_dynamic_packages () {
154 # Create packages for each SPA plugin. These plugins are located
155 # in individual subdirectories, so a recursive search is needed.
156 spa_libdir = d.expand('${libdir}/${SPA_SUBDIR}')
157 do_split_packages(d, spa_libdir, r'^libspa-(.*)\.so$', d.expand('${PN}-spa-plugins-%s'), 'PipeWire SPA plugin for %s', extra_depends='', recursive=True)
158
159 # Create packages for each PipeWire module.
160 pw_module_libdir = d.expand('${libdir}/${PW_MODULE_SUBDIR}')
161 do_split_packages(d, pw_module_libdir, r'^libpipewire-module-(.*)\.so$', d.expand('${PN}-modules-%s'), 'PipeWire %s module', extra_depends='', recursive=False)
162}
163
164python set_dynamic_metapkg_rdepends () {
165 import os
166 import oe.utils
167
168 # Go through all generated SPA plugin and PipeWire module packages
169 # (excluding the main package and the -meta package itself) and
170 # add them to the -meta package as RDEPENDS.
171
172 base_pn = d.getVar('PN')
173
174 spa_pn = base_pn + '-spa-plugins'
175 spa_metapkg = spa_pn + '-meta'
176
177 pw_module_pn = base_pn + '-modules'
178 pw_module_metapkg = pw_module_pn + '-meta'
179
180 d.setVar('ALLOW_EMPTY:' + spa_metapkg, "1")
181 d.setVar('FILES:' + spa_metapkg, "")
182
183 d.setVar('ALLOW_EMPTY:' + pw_module_metapkg, "1")
184 d.setVar('FILES:' + pw_module_metapkg, "")
185
186 blacklist = [ spa_pn, spa_metapkg, pw_module_pn, pw_module_metapkg ]
187 spa_metapkg_rdepends = []
188 pw_module_metapkg_rdepends = []
189 pkgdest = d.getVar('PKGDEST')
190
191 for pkg in oe.utils.packages_filter_out_system(d):
192 if pkg in blacklist:
193 continue
194
195 is_spa_pkg = pkg.startswith(spa_pn)
196 is_pw_module_pkg = pkg.startswith(pw_module_pn)
197 if not is_spa_pkg and not is_pw_module_pkg:
198 continue
199
200 if pkg in spa_metapkg_rdepends or pkg in pw_module_metapkg_rdepends:
201 continue
202
203 # See if the package is empty by looking at the contents of its
204 # PKGDEST subdirectory. If this subdirectory is empty, then then
205 # package is empty as well. Empty packages do not get added to
206 # the meta package's RDEPENDS.
207 pkgdir = os.path.join(pkgdest, pkg)
208 if os.path.exists(pkgdir):
209 dir_contents = os.listdir(pkgdir) or []
210 else:
211 dir_contents = []
212 is_empty = len(dir_contents) == 0
213 if not is_empty:
214 if is_spa_pkg:
215 spa_metapkg_rdepends.append(pkg)
216 if is_pw_module_pkg:
217 pw_module_metapkg_rdepends.append(pkg)
218
219 d.setVar('RDEPENDS:' + spa_metapkg, ' '.join(spa_metapkg_rdepends))
220 d.setVar('DESCRIPTION:' + spa_metapkg, spa_pn + ' meta package')
221
222 d.setVar('RDEPENDS:' + pw_module_metapkg, ' '.join(pw_module_metapkg_rdepends))
223 d.setVar('DESCRIPTION:' + pw_module_metapkg, pw_module_pn + ' meta package')
224}
225
226PACKAGES =+ "\
227 libpipewire \
228 ${PN}-tools \
229 ${PN}-pulse \
230 ${PN}-alsa \
231 ${PN}-jack \
232 ${PN}-spa-plugins \
233 ${PN}-spa-plugins-meta \
234 ${PN}-spa-tools \
235 ${PN}-modules \
236 ${PN}-modules-meta \
237 ${PN}-alsa-card-profile \
238 ${PN}-v4l2 \
239 gstreamer1.0-pipewire \
240"
241
242PACKAGES_DYNAMIC = "^${PN}-spa-plugins.* ^${PN}-modules.*"
243
244SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'systemd-system-service', 'pipewire.service', '', d)}"
245CONFFILES:${PN} += "${datadir}/pipewire/pipewire.conf"
246FILES:${PN} = " \
247 ${datadir}/pipewire \
248 ${systemd_system_unitdir}/pipewire* \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500249 ${systemd_user_unitdir} \
Patrick Williams92b42cb2022-09-03 06:53:57 -0500250 ${bindir}/pipewire \
251 ${bindir}/pipewire-avb \
252"
253
254RRECOMMENDS:${PN}:class-target += " \
255 pipewire-modules-meta \
256 pipewire-spa-plugins-meta \
257"
258
259FILES:${PN}-dev += " \
260 ${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so \
261"
262
263CONFFILES:libpipewire += "${datadir}/pipewire/client.conf"
264FILES:libpipewire = " \
265 ${datadir}/pipewire/client.conf \
266 ${libdir}/libpipewire-*.so.* \
267"
268# Add the bare minimum modules and plugins required to be able
269# to use libpipewire. Without these, it is essentially unusable.
270RDEPENDS:libpipewire += " \
271 ${PN}-modules-client-node \
272 ${PN}-modules-protocol-native \
273 ${PN}-spa-plugins-support \
274"
275
276FILES:${PN}-tools = " \
277 ${bindir}/pw-cat \
278 ${bindir}/pw-cli \
279 ${bindir}/pw-dot \
280 ${bindir}/pw-dsdplay \
281 ${bindir}/pw-dump \
282 ${bindir}/pw-link \
283 ${bindir}/pw-loopback \
284 ${bindir}/pw-metadata \
285 ${bindir}/pw-mididump \
286 ${bindir}/pw-midiplay \
287 ${bindir}/pw-midirecord \
288 ${bindir}/pw-mon \
289 ${bindir}/pw-play \
290 ${bindir}/pw-profiler \
291 ${bindir}/pw-record \
292 ${bindir}/pw-reserve \
293 ${bindir}/pw-top \
294"
295
296# This is a shim daemon that is intended to be used as a
297# drop-in PulseAudio replacement, providing a pulseaudio-compatible
298# socket that can be used by applications that use libpulse.
299CONFFILES:${PN}-pulse += "${datadir}/pipewire/pipewire-pulse.conf"
300FILES:${PN}-pulse = " \
301 ${datadir}/pipewire/pipewire-pulse.conf \
302 ${systemd_system_unitdir}/pipewire-pulse.* \
303 ${systemd_user_unitdir}/pipewire-pulse.* \
304 ${bindir}/pipewire-pulse \
305"
306RDEPENDS:${PN}-pulse += " \
307 ${PN}-modules-protocol-pulse \
308"
309
310# ALSA plugin to redirect audio to pipewire.
311FILES:${PN}-alsa = "\
312 ${libdir}/alsa-lib/* \
313 ${datadir}/alsa/alsa.conf.d/* \
314"
315
316# JACK drop-in libraries to redirect audio to pipewire.
317CONFFILES:${PN}-jack = "${datadir}/pipewire/jack.conf"
318FILES:${PN}-jack = "\
319 ${bindir}/pw-jack \
320 ${datadir}/pipewire/jack.conf \
321 ${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so.* \
322"
323
324# Dynamic SPA plugin packages (see set_dynamic_metapkg_rdepends).
325FILES:${PN}-spa-plugins = ""
326RRECOMMENDS:${PN}-spa-plugins += "${PN}-spa-plugins-meta"
327
328FILES:${PN}-spa-plugins-bluez5 += " \
329 ${datadir}/${SPA_SUBDIR}/bluez5/* \
330"
331
332FILES:${PN}-spa-tools = " \
333 ${bindir}/spa-* \
334"
335
336# Dynamic PipeWire module packages (see set_dynamic_metapkg_rdepends).
337FILES:${PN}-modules = ""
338RRECOMMENDS:${PN}-modules += "${PN}-modules-meta"
339
340CONFFILES:${PN}-modules-rt = "${datadir}/pipewire/client-rt.conf"
341FILES:${PN}-modules-rt += " \
342 ${datadir}/pipewire/client-rt.conf \
343 "
344
345CONFFILES:${PN}-modules-filter-chain = "${datadir}/pipewire/filter-chain/*"
346FILES:${PN}-modules-filter-chain += " \
347 ${datadir}/pipewire/filter-chain/* \
348"
349
350FILES:${PN}-alsa-card-profile = " \
351 ${datadir}/alsa-card-profile/* \
352 ${nonarch_base_libdir}/udev/rules.d/90-pipewire-alsa.rules \
353"
354
355# V4L2 interface emulator for sending/receiving data between PipeWire and V4L2 applications.
356FILES:${PN}-v4l2 += " \
357 ${bindir}/pw-v4l2 \
358 ${libdir}/${PW_MODULE_SUBDIR}/v4l2/libpw-v4l2.so \
359"
360
361FILES:gstreamer1.0-pipewire = " \
362 ${libdir}/gstreamer-1.0/* \
363"
364
365BBCLASSEXTEND = "native nativesdk"