blob: 19e4ee11ed68a2c31d3cf70a571ccbb2c54478fc [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# This recipe is modified from the recipe originally found in the Open-Switch
2# repository:
3#
4# https://github.com/open-switch/ops-build
5# yocto/openswitch/meta-foss-openswitch/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
6# Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9
7#
8# The recipe packaging has been relicensed under the MIT license for inclusion
9# in meta-openembedded by agreement of the author (Diego Dompe).
10#
11
12SUMMARY = "Tools to enhance VMWare guest integration and performance"
13HOMEPAGE = "https://github.com/vmware/open-vm-tools"
14DESCRIPTION = "\
15open-vm-tools is a set of services and modules that enable several features in VMware products \
16for better management of and seamless user interactions with guests.\
17"
18SECTION = "vmware-tools"
19
Patrick Williamsde0582f2022-04-08 10:23:27 -050020LICENSE = "LGPL-2.0-only & GPL-2.0-only & BSD-2-Clause & CDDL-1.0"
Andrew Geissler595f6302022-01-24 19:11:47 +000021LIC_FILES_CHKSUM = "file://LICENSE;md5=559317809c5444fb39ceaf6ac45c43ac"
Patrick Williamsde0582f2022-04-08 10:23:27 -050022LICENSE:modules/freebsd/vmblock = "BSD-2-Clause"
Andrew Geissler9aee5002022-03-30 16:27:02 +000023LICENSE:modules/freebsd/vmmemctl = "GPL-2.0-only"
24LICENSE:modules/freebsd/vmxnet = "GPL-2.0-only"
25LICENSE:modules/linux = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +000026LICENSE:modules/solaris = "CDDL-1.0"
27
28SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https;branch=master \
29 file://tools.conf \
30 file://vmtoolsd.service \
31 file://vmtoolsd.init \
32 file://0001-configure.ac-don-t-use-dnet-config.patch;patchdir=.. \
Patrick Williams2194f502022-10-16 14:26:09 -050033 file://0002-Use-configure-test-for-struct-timespec.patch;patchdir=.. \
34 file://0003-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch;patchdir=.. \
35 file://0004-Use-configure-to-test-for-feature-instead-of-platfor.patch;patchdir=.. \
36 file://0005-Use-configure-test-for-sys-stat.h-include.patch;patchdir=.. \
37 file://0006-Fix-subdir-objects-configure-error.patch;patchdir=.. \
38 file://0007-include-poll.h-instead-of-sys-poll.h.patch;patchdir=.. \
39 file://0008-Rename-poll.h-to-vm_poll.h.patch;patchdir=.. \
40 file://0009-use-posix-strerror_r-unless-on-gnu-libc-system.patch;patchdir=.. \
41 file://0010-Use-uintmax_t-for-handling-rlim_t.patch;patchdir=.. \
42 file://0011-Use-off64_t-instead-of-__off64_t.patch;patchdir=.. \
43 file://0012-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \
44 file://0013-open-vm-tools-Correct-include-path-for-poll.h.patch;patchdir=.. \
Andrew Geissler595f6302022-01-24 19:11:47 +000045 "
46
47UPSTREAM_CHECK_GITTAGREGEX = "stable-(?P<pver>\d+(\.\d+)+)"
48
49SRC_URI:append:libc-musl = " file://0001-Add-resolv_compat.h-for-musl-builds.patch;patchdir=.. \
50"
51
Patrick Williams2194f502022-10-16 14:26:09 -050052SRCREV = "6f5e4b13647b40a45c196dad76b1cb39cc6690b9"
Andrew Geissler595f6302022-01-24 19:11:47 +000053
54S = "${WORKDIR}/git/open-vm-tools"
55
56DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps libtirpc"
57
58# open-vm-tools is supported only on x86.
59COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
60
61inherit autotools pkgconfig systemd update-rc.d
62
63SYSTEMD_SERVICE:${PN} = "vmtoolsd.service"
64
65EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
66 --disable-tests --without-gtkmm --without-xerces --without-pam \
Patrick Williams2194f502022-10-16 14:26:09 -050067 --disable-vgauth --disable-deploypkg --disable-containerinfo \
Andrew Geissler595f6302022-01-24 19:11:47 +000068 --without-root-privileges --without-kernel-modules --with-tirpc \
69 --with-udev-rules-dir=${nonarch_base_libdir}/udev/rules.d"
70
71NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
72X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
73PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
74
75# fuse gets implicitly detected; there is no --without-fuse option.
76PACKAGECONFIG[fuse] = ",,fuse"
77
78CFLAGS:append:toolchain-clang = " -Wno-address-of-packed-member"
79FILES:${PN} += "\
80 ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
81 ${libdir}/open-vm-tools/plugins/common/lib*.so \
82 ${sysconfdir}/vmware-tools/tools.conf \
83"
84FILES:${PN}-locale += "${datadir}/open-vm-tools/messages"
85FILES:${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la"
86
87CONFFILES:${PN} += "${sysconfdir}/vmware-tools/tools.conf"
88
89RDEPENDS:${PN} = "util-linux libdnet fuse"
90
91do_install:append() {
92 if ! ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
93 install -d ${D}/sbin
94 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs
95 fi
96 install -d ${D}${sysconfdir}/vmware-tools
97 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
98 install -d ${D}${systemd_unitdir}/system
99 install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system
100 else
101 install -d ${D}${sysconfdir}/init.d
102 install -m 0755 ${WORKDIR}/vmtoolsd.init ${D}${sysconfdir}/init.d/vmtoolsd
103 fi
104 install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf
105}
106
107do_configure:prepend() {
108 export CUSTOM_DNET_NAME=dnet
109 export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so
110}
111
112INITSCRIPT_PACKAGES = "${PN}"
113INITSCRIPT_NAME:${PN} = "vmtoolsd"
114INITSCRIPT_PARAMS:${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ."
115
116python() {
117 if 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
118 raise bb.parse.SkipRecipe('Requires meta-filesystems to be present to provide fuse.')
119}