blob: d6b5f1987e6755b7d2cb52264f30284f9cdee75d [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
2HOMEPAGE = "https://github.com/cminyard/gensio"
3LICENSE = "GPL-2.0-only & LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
5 file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
6 "
7
8SRCREV = "b6cd354afe6d5f63bc859c94fd3a455a3cdf0449"
9
10SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=master \
11 file://0001-tools-gensiot-Fix-build-with-musl.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012 file://0001-configure-Check-for-request_init-API-when-probing-fo.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050013"
14
15S = "${WORKDIR}/git"
16
17inherit autotools
18
19PACKAGECONFIG ??= "openssl tcp-wrappers"
20
21PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
22PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
23PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
24
25EXTRA_OECONF = "--without-python"
26
27RDEPENDS:${PN} += "bash"