blob: 7332e28201b0f38450d6865251ea122476bb9376 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Open-source monitoring solution for your IT infrastructure"
2DESCRIPTION = "\
3ZABBIX is software that monitors numerous parameters of a network and the \
4health and integrity of servers. ZABBIX uses a flexible notification \
5mechanism that allows users to configure e-mail based alerts for virtually \
6any event. This allows a fast reaction to server problems. ZABBIX offers \
7excellent reporting and data visualisation features based on the stored \
8data. This makes ZABBIX ideal for capacity planning. \
9\
10ZABBIX supports both polling and trapping. All ZABBIX reports and \
11statistics, as well as configuration parameters are accessed through a \
12web-based front end. A web-based front end ensures that the status of \
13your network and the health of your servers can be assessed from any \
14location. Properly configured, ZABBIX can play an important role in \
15monitoring IT infrastructure. This is equally true for small \
16organisations with a few servers and for large companies with a \
17multitude of servers."
18HOMEPAGE = "http://www.zabbix.com/"
19SECTION = "Applications/Internet"
20LICENSE = "GPL-2.0-or-later"
21LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e"
22DEPENDS = "libevent libpcre openldap virtual/libiconv zlib"
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26SRC_URI = "https://cdn.zabbix.com/zabbix/sources/stable/6.2/${BPN}-${PV}.tar.gz \
27 file://0001-Fix-configure.ac.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050028 file://0001-initialize-msghdr-portably.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050029 file://zabbix-agent.service \
30"
Patrick Williams7784c422022-11-17 07:29:11 -060031SRC_URI[sha256sum] = "e2526603d9b487a26046de3022e1722b66f4b25542886b3e40a8e2b3bbdbd3b5"
Patrick Williams92b42cb2022-09-03 06:53:57 -050032
33inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd
34
35SYSTEMD_PACKAGES = "${PN}"
36SYSTEMD_SERVICE:${PN} = "zabbix-agent.service"
37SYSTEMD_AUTO_ENABLE = "enable"
38
39USERADD_PACKAGES = "${PN}"
40GROUPADD_PARAM:${PN} = "-r zabbix"
41USERADD_PARAM:${PN} = "-r -g zabbix -d /var/lib/zabbix \
42 -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \
43"
44
45KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}"
46
47EXTRA_OECONF = " \
48 --enable-dependency-tracking \
49 --enable-agent \
50 --enable-ipv6 \
51 --with-net-snmp \
52 --with-ldap=${STAGING_EXECPREFIXDIR} \
53 --with-unixodbc \
54 --with-ssh2 \
55 --with-sqlite3 \
56 --with-zlib \
57 --with-libpthread \
58 --with-libevent \
59 --with-libpcre=${STAGING_EXECPREFIXDIR} \
60 --with-iconv=${STAGING_EXECPREFIXDIR} \
61"
62CFLAGS:append = " -lldap -llber -pthread"
63
64do_configure:prepend() {
65 export KERNEL_VERSION="${KERNEL_VERSION}"
66}
67
68do_install:append() {
69 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
70 install -d ${D}${systemd_unitdir}/system
71 install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/
72 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service
73 fi
74}
75
76FILES:${PN} += "${libdir}"
77
78RDEPENDS:${PN} = "logrotate"