blob: 6befd31b8893364c16021deeecb86732442b5873 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "libass is a portable subtitle renderer for the ASS/SSA (Advanced Substation Alpha/Substation Alpha) subtitle format. It is mostly compatible with VSFilter."
2HOMEPAGE = "https://github.com/libass/libass"
3SECTION = "libs/multimedia"
4
5LICENSE = "ISC"
6LIC_FILES_CHKSUM = "file://COPYING;md5=a42532a0684420bdb15556c3cdd49a75"
7
8DEPENDS = "fontconfig freetype fribidi harfbuzz"
9
10SRC_URI = "git://github.com/libass/libass.git;protocol=https;branch=master"
11SRCREV = "1af6240c5d1e499326146e0b88c987e626b13c23"
12S = "${WORKDIR}/git"
13
14inherit autotools pkgconfig
15
16PACKAGECONFIG[asm] = "--enable-asm,--disable-asm,nasm-native"
17# use larger tiles in the rasterizer (better performance, slightly worse quality)
18PACKAGECONFIG[largetiles] = "--enable-large-tiles,--disable-large-tiles"
19
20PACKAGECONFIG ??= ""
21PACKAGECONFIG:append:x86-64 = " asm"
22
23PACKAGES =+ "${PN}-tests"
24
25FILES:${PN}-tests = " \
26 ${libdir}/test/test \
27"