blob: 73856d5704b050b9cca18d0214ac9f4125d4f1ce [file] [log] [blame]
Patrick Williams975a06f2022-10-21 14:42:47 -05001SUMMARY = "Utility that provides userspace support for reading and writing to the i.MX fuses"
2LICENSE = "GPL-3.0-only"
3LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=a64ced9463b8c81d08335d41966e0592"
4
5GO_IMPORT = "github.com/usbarmory/crucible"
6SRC_URI = "git://${GO_IMPORT}.git;protocol=https;branch=master"
7
8GO_INSTALL = "\
9 ${GO_IMPORT}/cmd/crucible \
10 ${GO_IMPORT}/cmd/habtool \
11"
12SRCREV = "837bdb65a20de240f92ea57727385352e06b977e"
13
14# Workaround for network access issue during compile step.
15# This needs to be fixed in the recipes buildsystem so that
16# it can be accomplished during do_fetch task.
17do_compile[network] = "1"
18
19inherit go-mod