blob: 7fc6d647287489b5dfc3fe40b62f236caf744e6f [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRIPTION = "A microbenchmark support library"
2HOMEPAGE = "https://github.com/google/benchmark"
3SECTION = "libs"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI = "git://github.com/google/benchmark.git;protocol=https;branch=main"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05008SRCREV = "361e8d1cfe0c6c36d30b39f1b61302ece5507320"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009
10S = "${WORKDIR}/git"
11
12EXTRA_OECMAKE = " \
13 -DBUILD_SHARED_LIBS=yes \
14 -DBENCHMARK_ENABLE_TESTING=no \
15 -DCMAKE_BUILD_TYPE=Release \
16"
17
18inherit cmake
19
20FILES:${PN}-dev += "${libdir}/cmake"