blob: 71040d0164a4a641bdd60e10981e2262711c362e [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "the compiling PHP template engine"
2SECTION = "console/network"
3HOMEPAGE = "https://www.smarty.net/"
4
5LICENSE = "GPL-3.0-only"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2c0f216b2120ffc367e20f2b56df51b3"
7
8DEPENDS += "php"
9
10SRC_URI = "git://github.com/smarty-php/smarty.git;protocol=https;branch=master"
11
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012SRCREV = "ffa2b81a8e354a49fd8a2f24742dc9dc399e8007"
Patrick Williams92b42cb2022-09-03 06:53:57 -050013
14S = "${WORKDIR}/git"
15
16do_install() {
17 install -d ${D}${datadir}/php/smarty3/libs/
18 install -m 0644 ${S}/libs/*.php ${D}${datadir}/php/smarty3/libs/
19
20 install -d ${D}${datadir}/php/smarty3/libs/plugins
21 install -m 0644 ${S}/libs/plugins/*.php ${D}${datadir}/php/smarty3/libs/plugins/
22
23 install -d ${D}${datadir}/php/smarty3/libs/sysplugins
24 install -m 0644 ${S}/libs/sysplugins/*.php ${D}${datadir}/php/smarty3/libs/sysplugins/
25}
26FILES:${PN} = "${datadir}/php/smarty3/"