blob: 1f2d3e0521e13ad5bf1c8ca10fc0c5ecbdd75fad [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
7
8SRC_URI = "http://fwts.ubuntu.com/release/fwts-V${PV}.tar.gz;subdir=${BP} \
9 file://0001-Add-correct-printf-qualifier-for-off_t.patch \
10 file://0003-Remove-Werror-from-build.patch \
11 file://0004-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \
12 file://0005-Undefine-PAGE_SIZE.patch \
13 file://0006-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
14 "
15SRC_URI[sha256sum] = "45045a095d9933d9ff39712372ab1f3078ca8e29c007b3f97b810cdb8c27b5c3"
16
17COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
18
19DEPENDS = "libpcre glib-2.0 dtc bison-native libbsd"
20DEPENDS:append:libc-musl = " libexecinfo"
21
22inherit autotools bash-completion pkgconfig
23
24LDFLAGS:append:libc-musl = " -lexecinfo"
25
26# We end up linker barfing with undefined symbols on ppc64 but not on other arches
27# surprisingly
28ASNEEDED:powerpc64le = ""
29
30FILES:${PN} += "${libdir}/fwts/lib*${SOLIBS}"
31FILES:${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
32FILES:${PN}-staticdev += "${libdir}/fwts/lib*a"
33
34RDEPENDS:${PN} += "dtc"