blob: 3fa4fb17b4d3f196990f50ca4c3e8aa088cd62a6 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A simple, sane and efficient module to slurp a file"
2DESCRIPTION = "This module provides functions for fast and correct slurping and spewing. \
3All functions are optionally exported. All functions throw exceptions on \
4errors, write functions don't return any meaningful value."
5
6SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00008
9HOMEPAGE= "https://metacpan.org/release/File-Slurper"
10
11LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
12file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/File-Slurper-${PV}.tar.gz"
15
16SRC_URI[sha256sum] = "e2f6a4029a6a242d50054044f1fb86770b9b5cc4daeb1a967f91ffb42716a8c5"
17RDEPENDS:${PN} = " \
18 perl-module-carp \
19 perl-module-encode \
20 perl-module-exporter \
21 perl-module-perlio \
22 perl-module-perlio-encoding \
23 perl-module-strict \
24 perl-module-warnings \
25"
26
27RDEPENDS:${PN}-ptest += "libtest-warnings-perl \
28 perl-module-test-more \
29 "
30
31S = "${WORKDIR}/File-Slurper-${PV}"
32
33inherit cpan ptest-perl
34
35BBCLASSEXTEND = "native"