blob: 65cd29d9b408cc7b112c25616a0da550012b162c [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
Andrew Geissler87f5cff2022-09-30 13:13:31 -05007LIC_FILES_CHKSUM = "file://LICENSE;md5=c1cc9ab35a8b2aabf933cd6d245b5db3"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008
Patrick Williams2390b1b2022-11-03 13:47:49 -05009SRC_URI[sha256sum] = "249cec5f2a5b22096440bd85c33106b6102e0672204abd2d5c014106459804ee"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010
11inherit pypi setuptools3
12
13DEPENDS += " \
14 ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
15"
16
17CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-numpy \
22 ${PYTHON_PN}-dateutil \
23 ${PYTHON_PN}-dateutil-zoneinfo \
24 ${PYTHON_PN}-pytz \
25 ${PYTHON_PN}-profile \
26"