blob: 0b8962dedf20e12777e42890474e9840789dbe93 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Library for building powerful interactive command lines in Python"
2HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
5
Andrew Geissler87f5cff2022-09-30 13:13:31 -05006SRC_URI[sha256sum] = "9ada952c9d1787f52ff6d5f3484d0b4df8952787c087edf6a1f7c2cb1ea88148"
Patrick Williams92b42cb2022-09-03 06:53:57 -05007
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "prompt_toolkit"
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-six \
15 ${PYTHON_PN}-terminal \
16 ${PYTHON_PN}-threading \
17 ${PYTHON_PN}-wcwidth \
18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-image \
21 ${PYTHON_PN}-asyncio \
22 ${PYTHON_PN}-xml \
23"
24
25BBCLASSEXTEND = "native nativesdk"