blob: 7c822ac23f826febd5eb6a1177e3bef26e9fe227 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Python bindings for DBus AT-SPI2 accessibility"
2DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca"
3SECTION = "devel/python"
4HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=db29218e6ba3794c56df7d4987dc7e4d \
7 file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
8DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject"
9
10SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=master"
11SRCREV = "141a53029b3e16bfa5f100ae54a77234a9bf3426"
12
13S = "${WORKDIR}/git"
14
15# Same restriction as gtk+
16inherit features_check setuptools3
17ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
18
19inherit pkgconfig autotools python3native
20
21FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*"