blob: d2de4d3b747a97d553b7caafa632979f08e829bc [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Python interface for c-ares"
2DESCRIPTION = "\
3pycares is a Python module which provides an interface to c-ares. c-ares is \
4a C library that performs DNS requests and name resolutions asynchronously."
5HOMEPAGE = "https://github.com/saghul/pycares"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b1538fcaea82ebf2313ed648b96c69b1"
8
9SRC_URI[sha256sum] = "e1f57a8004370080694bd6fb969a1ffc9171a59c6824d54f791c1b2e4d298385"
10
11PYPI_PACKAGE = "pycares"
12
13inherit pypi setuptools3
14
15DEPENDS += "${PYTHON_PN}-cffi-native"
16
17RDEPENDS:${PN} += " \
18 ${PYTHON_PN}-cffi \
19 ${PYTHON_PN}-idna \
20"