blob: 69372060bcde567397fd1c7cb6629fbb2cc96697 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Library for Python 3.6+ to communicate with the Google Chromecast."
2HOMEPAGE = "https://github.com/balloob/pychromecast"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5"
5
Andrew Geissler615f2f12022-07-15 14:00:58 -05006SRC_URI[sha256sum] = "9e57dc985a4a05db5bdcd5da219cbf6ced25548ca093f8d74bc107b3c554ec00"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8PYPI_PACKAGE = "PyChromecast"
9
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-logging \
14 ${PYTHON_PN}-zeroconf \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-requests \
17 ${PYTHON_PN}-protobuf \
Andrew Geissler615f2f12022-07-15 14:00:58 -050018 ${PYTHON_PN}-compression \
Andrew Geissler9aee5002022-03-30 16:27:02 +000019"