blob: a900e70279791d35b6134b4f15b67f1f946a7a78 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main"
7SRCREV = "b1892efb6a078d1370cee51c9103f3a591c628d2"
8S = "${WORKDIR}/git"
9
10inherit python_poetry_core
11
12PIP_INSTALL_PACKAGE = "pymisp"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-dateutil \
16 ${PYTHON_PN}-json \
17 ${PYTHON_PN}-jsonschema \
18 ${PYTHON_PN}-requests \
19 ${PYTHON_PN}-six \
20 ${PYTHON_PN}-deprecated \
21 ${PYTHON_PN}-wrapt \
22"
23
24# Fixes: python3-pymisp requires /bin/bash, but no
25# providers found in RDEPENDS:python3-pymisp? [file-rdep]
26RDEPENDS:${PN} += "bash"