blob: fa43b7f403937459bf07391ec38d3dead6c68231 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
2DESCRIPTION = "\
3The PyMongo distribution contains tools for interacting with MongoDB \
4database from Python. The bson package is an implementation of the BSON \
5format for Python. The pymongo package is a native Python driver for \
6MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
7HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
Patrick Williams2390b1b2022-11-03 13:47:49 -050011SRC_URI[sha256sum] = "95913659d6c5fc714e662533d014836c988cc1561684f07b6a0a8343651afa66"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
13inherit pypi setuptools3
14
15PACKAGES =+ "${PYTHON_PN}-bson"
16
17FILES:${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
18
19RDEPENDS:${PYTHON_PN}-bson += " \
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-netclient \
23 ${PYTHON_PN}-numbers \
24 ${PYTHON_PN}-threading \
25"
26
27RDEPENDS:${PN} += " \
28 ${PYTHON_PN}-bson \
29 ${PYTHON_PN}-pprint \
30"