blob: 13933b6cd90d271b263959d1963a293c6972826e [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Sensors plugin for the Xfce Panel"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=b94789bed9aec03b9656a9cc5398c706"
5
6inherit xfce-panel-plugin
7
Patrick Williamsde0582f2022-04-08 10:23:27 -05008SRC_URI[sha256sum] = "171c0235f70c65f0ffee587e960d9da79b284855df22130239eac26272ec06c9"
Andrew Geissler595f6302022-01-24 19:11:47 +00009SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch"
10
11EXTRA_OECONF = " \
12 --disable-procacpi \
13 --disable-xnvctrl \
14"
15
16do_configure:prepend() {
17 sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
18}
19
Patrick Williamsde0582f2022-04-08 10:23:27 -050020PACKAGECONFIG ??= "libnotify"
Andrew Geissler595f6302022-01-24 19:11:47 +000021PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
22PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
23PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"
24PACKAGECONFIG[libnotify] = "--enable-notification,--disable-notification, libnotify"
25
26FILES_SOLIBSDEV = "${libdir}/xfce4/modules/lib*${SOLIBSDEV}"