blob: 921defda9e9de50b5ea09f0b04c2baf6c6428e16 [file] [log] [blame]
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05001DESCRIPTION = "Unprivileged sandboxing tool"
2HOMEPAGE = "https://github.com/containers/bubblewrap"
3LICENSE = "LGPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
5
6DEPENDS = "libcap"
7
8SRC_URI = "https://github.com/containers/${BPN}/releases/download/v${PV}/${BP}.tar.xz"
9SRC_URI[sha256sum] = "8a0ec802d1b3e956c5bb0a40a81c9ce0b055a31bf30a8efa547433603b8af20b"
10
11UPSTREAM_CHECK_URI = "https://github.com/containers/bubblewrap/releases"
12UPSTREAM_CHECK_REGEX = "bubblewrap-(?P<pver>\d+(\.\d+)+)\.tar"
13
14inherit autotools bash-completion manpages pkgconfig
15
16PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
17PACKAGECONFIG[manpages] = "--enable-man,--disable-man,libxslt-native docbook-xsl-stylesheets-native xmlto-native"
18PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
19PACKAGECONFIG[setuid] = "--with-priv-mode=setuid,--with-priv-mode=none"
20
21PACKAGES += "${PN}-zsh-completion"
22
23FILES:${PN}-zsh-completion = "${datadir}/zsh/site-functions"