blob: 78174760306908f2f5e172a3b8426b66263ac3f0 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Embedded Linux Library"
2HOMEPAGE = "https://01.org/ell"
3DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
4low-level functionality for system daemons. It typically has no \
5dependencies other than the Linux kernel, C standard library, and \
6libdl (for dynamic linking). While ELL is designed to be efficient \
7and compact enough for use on embedded Linux platforms, it is not \
8limited to resource-constrained systems."
9SECTION = "libs"
10LICENSE = "LGPL-2.1-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
12
13DEPENDS = "dbus"
14
15inherit autotools pkgconfig
16
17SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050018SRC_URI[sha256sum] = "a7d0df846af839bbea1b80f292166371070328854b3fa785b5c607fe600552ad"
Patrick Williams92b42cb2022-09-03 06:53:57 -050019
20do_configure:prepend () {
21 mkdir -p ${S}/build-aux
22}