blob: 1eed2cde4150467cfd7235ef5fdf95b74eedc19a [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
2
3SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
4HOMEPAGE = " http://golang.org/"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
7
8PROVIDES = "go-native"
9
Patrick Williams2390b1b2022-11-03 13:47:49 -050010# Checksums available at https://go.dev/dl/
Patrick Williams92b42cb2022-09-03 06:53:57 -050011SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
Patrick Williams2390b1b2022-11-03 13:47:49 -050012SRC_URI[go_linux_amd64.sha256sum] = "74b9640724fd4e6bb0ed2a1bc44ae813a03f1e72a4c76253e2d5c015494430ba"
13SRC_URI[go_linux_arm64.sha256sum] = "99de2fe112a52ab748fb175edea64b313a0c8d51d6157dba683a6be163fd5eab"
14SRC_URI[go_linux_ppc64le.sha256sum] = "741dad06e7b17fe2c9cd9586b4048cec087ca1f7a317389b14e89b26c25d3542"
Patrick Williams92b42cb2022-09-03 06:53:57 -050015
16UPSTREAM_CHECK_URI = "https://golang.org/dl/"
17UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
18
19S = "${WORKDIR}/go"
20
21inherit goarch native
22
23do_compile() {
24 :
25}
26
27make_wrapper() {
28 rm -f ${D}${bindir}/$1
29 cat <<END >${D}${bindir}/$1
30#!/bin/bash
31here=\`dirname \$0\`
32export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
33\$here/../lib/go/bin/$1 "\$@"
34END
35 chmod +x ${D}${bindir}/$1
36}
37
38do_install() {
39 find ${S} -depth -type d -name testdata -exec rm -rf {} +
40
41 install -d ${D}${bindir} ${D}${libdir}/go
42 cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
43
44 for f in ${S}/bin/*
45 do
46 make_wrapper `basename $f`
47 done
48}