blob: 1b6c76323b0f72b4d3f01486dc6253b62d387aa1 [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "Poetry PEP 517 Build Backend"
2DESCRIPTION = "Poetry PEP 517 Build Backend"
3HOMEPAGE = "https://github.com/python-poetry/poetry-core"
4BUGTRACKER = "https://github.com/python-poetry/poetry-core"
5CHANGELOG = "https://github.com/python-poetry/poetry-core/blob/master/CHANGELOG.md"
6
7LICENSE = "Apache-2.0 & BSD-2-Clause & MIT"
8LIC_FILES_CHKSUM = "\
9 file://LICENSE;md5=78c39cfd009863ae44237a7ab1f9cedc \
10 file://src/poetry/core/_vendor/attr/_version_info.py;beginline=1;endline=1;md5=b2dccaa94b3629a08bfb4f983cad6f89 \
11 file://src/poetry/core/_vendor/attrs/LICENSE;md5=5e55731824cf9205cfabeab9a0600887 \
12 file://src/poetry/core/_vendor/jsonschema/COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
13 file://src/poetry/core/_vendor/lark/LICENSE;md5=b37b83a9cf129d92ee65aaa71c01ce72 \
14 file://src/poetry/core/_vendor/packaging/LICENSE;md5=faadaedca9251a90b205c9167578ce91 \
15 file://src/poetry/core/_vendor/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \
16 file://src/poetry/core/_vendor/packaging/LICENSE.BSD;md5=7bef9bf4a8e4263634d0597e7ba100b8 \
17 file://src/poetry/core/_vendor/pyparsing/LICENSE;md5=657a566233888513e1f07ba13e2f47f1 \
18 file://src/poetry/core/_vendor/pyrsistent/LICENSE.mit;md5=b695eb9c6e7a6fb1b1bc2d193c42776e \
19 file://src/poetry/core/_vendor/tomlkit/LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82 \
20 file://src/poetry/core/_vendor/typing_extensions.LICENSE;md5=64fc2b30b67d0a8423c250e0386ed72f \
21"
22
23SRC_URI[sha256sum] = "0ab006a40cb38d6a38b97264f6835da2f08a96912f2728ce668e9ac6a34f686f"
24
25inherit python_poetry_core pypi
26
27RDEPENDS:${PN}:append:class-target = "\
28 python3-compression \
29 python3-core \
30 python3-crypt \
31 python3-io \
32 python3-json \
33 python3-logging \
34 python3-netclient \
35 python3-pathlib2 \
36 python3-pprint \
37 python3-shell \
38"
39
40RDEPENDS:${PN} += "\
41 python3-pip \
42 python3-six \
43"
44
45BBCLASSEXTEND = "native nativesdk"