blob: b692067809308399319d573be8a3d4552d327b00 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Python bindings for the Cairo canvas library"
2HOMEPAGE = "http://cairographics.org/pycairo"
3BUGTRACKER = "http://bugs.freedesktop.org"
4SECTION = "python-devel"
5LICENSE = "LGPL-2.1-only & MPL-1.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=f3713ca2c28d9312ad718520b6dc3eee \
7 file://COPYING-LGPL-2.1;md5=fad9b3332be894bab9bc501572864b29 \
8 file://COPYING-MPL-1.1;md5=bfe1f75d606912a4111c90743d6c7325"
9
10# cairo >= 1.14
11DEPENDS = "cairo python3"
12
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/pycairo-${PV}.tar.gz"
14GITHUB_BASE_URI = "https://github.com/pygobject/pycairo/releases/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000015
16SRC_URI[sha256sum] = "251907f18a552df938aa3386657ff4b5a4937dde70e11aa042bc297957f4b74b"
17
18S = "${WORKDIR}/pycairo-${PV}"
19
Andrew Geissler87f5cff2022-09-30 13:13:31 -050020inherit meson pkgconfig python3targetconfig github-releases
Andrew Geissler9aee5002022-03-30 16:27:02 +000021
22CFLAGS += "-fPIC"
23
24BBCLASSEXTEND = "native"
25
26FILES:${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"