blob: 70b4e23def14bc4c5c0b2146d281856b53e4bd12 [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=72c536e78c21c567311b193fe00cd253"
6
7PYPI_PACKAGE = "Sphinx"
8
9SRC_URI[sha256sum] = "51026de0a9ff9fc13c05d74913ad66047e104f56a129ff73e174eb5c3ee794b5"
10
11inherit python_flit_core pypi
12
13
14do_install:append () {
15 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
16 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
17}
18
19RDEPENDS:${PN} = "\
20 python3-alabaster \
21 python3-babel \
22 python3-docutils \
23 python3-imagesize \
24 python3-jinja2 \
25 python3-packaging \
26 python3-pygments \
27 python3-requests \
28 python3-snowballstemmer \
29 python3-sphinxcontrib-applehelp \
30 python3-sphinxcontrib-devhelp \
31 python3-sphinxcontrib-htmlhelp \
32 python3-sphinxcontrib-jsmath \
33 python3-sphinxcontrib-qthelp \
34 python3-sphinxcontrib-serializinghtml \
35 "
36
37BBCLASSEXTEND = "native nativesdk"