blob: 6f599f5b78161b0e7ced712d2d03f6ec4508c7e3 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPL-2.0-or-later"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introspection
17
18UPSTREAM_CHECK_REGEX = "pango-(?P<pver>\d+\.(?!9\d+)\d+\.\d+)"
19
20GIR_MESON_ENABLE_FLAG = "enabled"
21GIR_MESON_DISABLE_FLAG = "disabled"
22
23SRC_URI += "file://run-ptest \
Patrick Williams7784c422022-11-17 07:29:11 -060024 file://0001-Skip-running-test-layout-test.patch \
25 file://0001-tests-meson.build-install-nofonts-fonts.conf-as-it-i.patch \
26 "
Patrick Williams92b42cb2022-09-03 06:53:57 -050027
Patrick Williams7784c422022-11-17 07:29:11 -060028SRC_URI[archive.sha256sum] = "8800f812d89ee61388188703203f3a7878963c22f8695aaf1fa0a1a1428d17ae"
Patrick Williams92b42cb2022-09-03 06:53:57 -050029
30DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
31
32PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
33 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
34
35PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
36PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
37PACKAGECONFIG[thai] = ",,libthai"
38
39GIR_MESON_OPTION = 'introspection'
40
41do_configure:prepend() {
Patrick Williams7784c422022-11-17 07:29:11 -060042 chmod +x ${S}/tests/*.py
Patrick Williams92b42cb2022-09-03 06:53:57 -050043}
44
45LEAD_SONAME = "libpango-1.0*"
46
47FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
48
49RDEPENDS:${PN}-ptest += "cantarell-fonts"
50RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
51
52RPROVIDES:${PN} += "pango-modules pango-module-indic-lang \
53 pango-module-basic-fc pango-module-arabic-lang"
54
55BBCLASSEXTEND = "native nativesdk"