blob: c340646fa780fa41deeeb6625462f2a327ed400d [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A collection of tools, libraries and tests for shader compilation"
2DESCRIPTION = "The Shaderc library provides an API for compiling GLSL/HLSL \
3source code to SPIRV modules. It has been shipping in the Android NDK since version r12b."
4SECTION = "graphics"
5HOMEPAGE = "https://github.com/google/shaderc"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
Patrick Williams7784c422022-11-17 07:29:11 -06009SRCREV = "4bbb646ddb3279c6a27e7aa0eb86c10c8add987b"
Patrick Williams92b42cb2022-09-03 06:53:57 -050010SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
11 file://0001-cmake-disable-building-external-dependencies.patch \
12 file://0002-libshaderc_util-fix-glslang-header-file-location.patch \
Patrick Williams7784c422022-11-17 07:29:11 -060013 file://0001-CMakeLists.txt-drop-OSDependent-OGLCompiler-from-lis.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050014 "
15UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$"
16S = "${WORKDIR}/git"
17
18inherit cmake python3native pkgconfig
19
20DEPENDS = "spirv-headers spirv-tools glslang"
21
22EXTRA_OECMAKE = " \
23 -DCMAKE_BUILD_TYPE=Release \
24 -DBUILD_EXTERNAL=OFF \
25 -DSHADERC_SKIP_TESTS=ON \
26 -DSHADERC_SKIP_EXAMPLES=ON \
27 -DSHADERC_SKIP_COPYRIGHT_CHECK=ON \
28"
29
30BBCLASSEXTEND = "native nativesdk"